There is now an exploit for PS4 consoles running firmware 5.05

Posts

Hardware / Posts 197 Views

Earlier this year, console modders found the first crack in the PS4’s armor, developing an exploit to run homebrew software and unlock full PS2 backwards compatibility. The catch was that in order to take advantage, you would need a PS4 running either firmware version 4.05 or 4.55. Since then, SpecterDev has been catching up with Sony fairly quickly, with the latest kernel exploit targeting the console’s 5.05 firmware, which was only released in January of this year.

The PS4 5.05 crack paves the way for several things. For starters, users can unlock full PS2 backwards compatibility, install emulators or run homebrew software. Of course, it also enables piracy, which is something that Sony will be particularly concerned with clamping down on.

Taking advantage of this exploit is very simple and the instructions are easy enough to find. However, the exploit is not permanent, users will have to go through the set up process each time their PS4 fully turns off- it is persistent when coming in and out of ‘rest mode’ though.

This exploit has been working for a while now, but the developers chose to delay the release of it in order to curb immediate piracy of some of Sony’s major exclusives, like God of War.

Rumour has it that a 5.55 kernel exploit is already developed and working in private. This is the very latest version of Sony’s PS4 firmware, which would mean that cracked PS4s could be on par with the latest updates from Sony. With that in mind, the console’s last few years of life could end up being somewhat difficult.

KitGuru Says: These kernel exploits are always fantastic bits of work from the community, but they open the floodgates for piracy, despite the best efforts to divert attention away from it. Do you think that developers should sit on their discovery or are they right to share it?

Comments